How to Create Tables of Content for Long Projects Using Lists (Cross-platform)

Our Technical Support Portal has changed as we have moved to a new platform. Please visit support.quark.com to access your support tickets or to log a new ticket with us. All our existing customers should look for an email from support@quark.com for activation of their New Support Account. If you face any difficulty in accessing the new portal, please write to us at support@quark.com

How to Create Tables of Content for Long Projects Using Lists (Cross-platform)

The Lists feature in QuarkXPress will enable you to generate a table of contents for you layout. If you are using the Book feature in conjunction with QuarkXPress Lists, you can build a Table of Contents for the entire Book.

In order to build a Table of Contents, you will need to follow a three-step process. First, define all your Style Sheets to be used in the project. Once these are built, you can use them to build your Lists. Once youÂ’ve built your lists, you can then build your Table of Contents from the Lists.

Step 1:  Build your Paragraph Style Sheets

  1. Create your Paragraph Style Sheets (Edit > Style Sheets) and apply these style sheets to the paragraphs you want included in your table of contents. Name these style sheets so that they can be easily identified, such as you name heads and subheads. (Note: Each row in the table of contents is limited to 256 characters.)
  2. Create a second set of paragraph style sheets. These style sheets will be used to format the actual entries of the table of contents that the lists feature will generate. These style sheets should not have the same name as the ones used above.
    TIP: You might want to create different style sheets to format each level of your table of contents, so you can specify different indent values. When you build the table of contents, QuarkXPress will insert a tab space to separate the text and the page numbers; so you may also want to specify a tab setting, and even a fill character, to align the text or page numbers.
  3. If you are also using the Books feature, click the Synchronize icon in the Book palette, the style sheets in the master chapter will be added to the other chapters of the book automatically. If a style sheet of the same name exists in another chapter, the values of the style sheet will be changed to reflect the values in the master chapter. Any text styled with the previous values will appear as locally formatted.

Step 2: Creating/Defining a list

  1. Go to Edit > Lists and click New.
  2. Enter a name in the Name field.
  3. Choose style sheets from the Available Styles scroll list and click the Add arrow (right arrow) to add them to the Styles in List scroll list. The text that has these style sheets applied to it will be included in your table of contents.
    (Note: A maximum of 32 style sheets can be used in a list.)
  4. Choose a level from the Level pop-up menu for each style sheet. Each level after the first will be indented in the Lists palette.
  5. Choose a Numbering option to specify where the page numbers will appear in relation to the table of contents text.
  6. Choose a style sheet from the Format As pop-up menu to specify how the text of the table of contents will be formatted. Do not select the same style sheet in the Name and Format As fields; if you do, duplicate entries will occur whenever you 'rebuild' the list.
  7. Click OK to return to the Lists dialog box; then click Save.
  8. Choose File > Save.
  9. Click the Synchronize icon in the Book palette to add the newly defined list to all of the chapters in the book. This is an important step; if you do not synchronize, you will not be able to build a table of contents for the entire book.

 Step 3:  Building a List/Table of Contents

  1. Create the pages that will contain the table of contents.
  2. Choose Window > Lists.
  3. Choose the name of the open project (or Book) from the Show List For pop-up menu.
  4. Click Update to scan all the chapters in the book and display all the list entries in the Lists palette. Review the list entries carefully.
  5. Create a text box to contain the table of contents.
  6. Click the text box once to activate it, and then click Build in the Lists palette. (If a list of the same name has already been built, an alert will display. You can click Insert to create another table of contents or click Replace to replace the previous table of contents.)

More Information: Troubleshooting tips

 

 

  • If you edit text in the project, you must click Update in the Lists palette and rebuild the list in order for these changes to display in the table of contents.
  • If blank lines (or squares) display in the Lists palette, the style sheets used to generate the table of contents may be applied to paragraph breaks or automatic page numbers. Double-click a blank row in the Lists palette to display the location of the paragraph break or page number in the project. Apply No Style (Window > Styles) to the paragraph break or page number. Click Update in the Lists palette, then rebuild the list.
  • If text does not appear in the table of contents, make sure that the text has the appropriate paragraph style sheet applied to it. Also, make sure that the style sheet is included in the list (Edit > Lists).
  • If the page numbers in the table of contents are wrong, make sure that the text boxes containing the table of contents did not displace other paragraphs. If a paragraph location has changed in the project, be sure to click Update in the Lists palette and rebuild the list.
  • You can type a word in the Find field of the Lists palette and then press Return or Enter to quickly find the word in the palette. Also, you can double-click a row in the Lists palette to display the location of the text in the project.
  • If the text used to generate the table of contents is in different text boxes on the same page, the text in the box on the front-most layer will display first in the table of contents. (In general, the last box created on a page will be on the front-most layer.) You can use the Send to Back or Bring to Front command (Item menu) to change the layering of the text boxes. Then click Update and rebuild the list.

 

Rating:Rating of 3.5 Stars3 Votes
Was this answer helpful?YesNo
Topic Information
  • Topic #: 30026-1199
  • Date Created: 11/20/2012
  • Last Modified Since: 09/05/2016
  • Viewed: 4069